CMTrace log viewer

CMTrace is a great log viewer:

http://www.adamtheautomator.com/building-logs-for-cmtrace-powershell/

Nice to have as it is showing errors and warnings in different colours and gives you possiblity to look at the log in the real time as it is still building:

https://www.microsoft.com/en-us/download/details.aspx?id=50012

Toolkit default installation path is “C:\Program Files (x86)\ConfigMgr 2012 Toolkit R2”.

IT IS FRIDAY!

9a4a98367ecac8a48762257dc4aedece

Advertisements

SCCM 2012 – *.bat files are not being copied to distribution point

We’ve recently installed the new IntelSCS addon for AMT Vpro on SCCM 2012 -> https://downloadcenter.intel.com/Detail_Desc.aspx?lang=eng&DwnldID=20921

Couple of days ago I had this strange ticket form our application administrator, he told me that there is some sort of problem with IntelSCS package (that was automatically created by the IntelSCS addon). In workstation log I found information that file “Remote_Discover.bat” was not found:

workstation_error_log

That was bit of strange, additionally because this package was created by the addon itself.

The first step was to check if those files are in the distribution point, it appeared that all files, beside all *.bat files, were copied successfuly:

dp_files

I checked the source path in packade, it was ok. It was pointing to the “Local folder on site server” it was like E:\…. and was ok, the bat files was also there.

I reached to the bottom of my mind ๐Ÿ˜‰ and reminded that it might be something with that local paths, I have changed the path to “Network path (UNC name)“. After updating distribution point with that package – guess what :), it was ok now:

dp_files_bat

So if some of your files won’t distribute, firstly think about changing the path to the sources from Localย  to UNC.

[SOLVED] SCCM 2012, “waiting for content” problem with ID 10035 and KB2840628

Lately I have received complaining from my colleagues from Helpdesk that no packages are being deployed on workstations.

All they saw is 0% of compliance and it didn’t seem to go any further.

I made a package with GIMP and deployed it to my workstation

I looked at my workstation’s logs, and this is what I have received in DataTransferService.log:

UpdateURLWithTransportSettings(): OLD URL – http://SCCMSRV01.domain.pl/SMS_MP DataTransferService 2013-08-02 10:52:28 44312 (0xAD18)
UpdateURLWithTransportSettings(): NEW URL – http://SCCMSRV01.domain.pl:80/SMS_MP DataTransferService 2013-08-02 10:52:28 44312 (0xAD18)
Added (source=.sms_pol?WRO20146-WRO0006A-9A35FD00.1_00,dest={1FEF9F05-C6EE-4825-ABA3-A0524765E569}.tmp) pair from manifest. DataTransferService 2013-08-02 10:52:28 44312 (0xAD18)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} created to download from ‘http://SCCMSRV01.domain.pl:80/SMS_MP’ to ‘C:\Windows\CCM\Temp’. DataTransferService 2013-08-02 10:52:28 44312 (0xAD18)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} in state ‘PendingDownload’. DataTransferService 2013-08-02 10:52:28 61696 (0xF100)
DTSFlag is 0x0000bc8a DataTransferService 2013-08-02 10:52:29 61696 (0xF100)
Exclude file list: DataTransferService 2013-08-02 10:52:29 61696 (0xF100)
Using branch cache option DataTransferService 2013-08-02 10:52:29 61696 (0xF100)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} in state ‘DownloadingData’. DataTransferService 2013-08-02 10:52:29 61696 (0xF100)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} in state ‘RetrievedData’. DataTransferService 2013-08-02 10:52:47 61672 (0xF0E8)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} successfully completed download. DataTransferService 2013-08-02 10:52:47 61672 (0xF0E8)
DTSJob {F7B9EB0E-F104-4A8F-B884-771D78205282} in state ‘NotifiedComplete’. DataTransferService 2013-08-02 10:52:47 44312 (0xAD18)
DTS job {F7B9EB0E-F104-4A8F-B884-771D78205282} has completed:
Status : SUCCESS,
Start time : 08/02/2013 10:52:28,
Completion time : 08/02/2013 10:52:47,
Elapsed time : 18 seconds DataTransferService 2013-08-02 10:52:47 44312 (0xAD18)

So for me it seemed everything was allright, later I have checked the ContentTransferManager.log:

Starting CTM job {8BBAAE65-7549-4B57-8651-630B600FF7BC}. ContentTransferManager 2013-08-02 07:07:37 7428 (0x1D04)
Starting CTM job {AB9D3FC4-17FF-484B-BD7E-288BF695E026}. ContentTransferManager 2013-08-02 10:52:48 61696 (0xF100)
Created CTM job {AB9D3FC4-17FF-484B-BD7E-288BF695E026} for user S-1-5-18 ContentTransferManager 2013-08-02 10:52:48 61696 (0xF100)
Created and Sent Location Request ‘{E5143893-7C75-421E-898A-8C4DE7CE57FA}’ for package WRO0006A ContentTransferManager 2013-08-02 10:52:48 55380 (0xD854)
CTM job {AB9D3FC4-17FF-484B-BD7E-288BF695E026} entered phase CCM_DOWNLOADSTATUS_DOWNLOADING_DATA ContentTransferManager 2013-08-02 10:52:48 55380 (0xD854)
Queued location request ‘{E5143893-7C75-421E-898A-8C4DE7CE57FA}’ for CTM job ‘{AB9D3FC4-17FF-484B-BD7E-288BF695E026}’. ContentTransferManager 2013-08-02 10:52:48 55380 (0xD854)

Here also seemed to be ok, but after a while, it wasn’t going to Persisted locations for CTM job line, the next line should look like this:

Persisted locations for CTM job {56F1683C-F883-411E-B963-6A868147EA10}:
(LOCAL) http://SCCM01SRV.domain.pl/SMS_DP_SMSPKG$/Content_bc428407-54be-40f7-ab09-518d83f591c8.1 ContentTransferManager 2013-07-04 12:19:35 33744 (0x83D0)

So I looked at the execmgr.log

The logged on user is domain.pl\pawel.jarosz execmgr 2013-08-02 07:07:49 5392 (0x1510)
Requesting content from CAS for package WRO0006A version 1 execmgr 2013-08-02 10:52:48 61696 (0xF100)
Policy arrived for parent package WRO0006A program Gimp 2.8.4 execmgr 2013-08-02 10:52:48 61672 (0xF0E8)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID=”WRO0006A”,ProgramID=”Gimp 2.8.4″, actionType 6l, value NULL, user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 2013-08-02 10:52:48 61672 (0xF0E8)
Raising event:
[SMS_CodePage(852), SMS_LocaleID(1045)]
instance of SoftDistProgramOfferReceivedEvent
{
AdvertisementId = “WRO20146”;
ClientID = “GUID:9CD52450-3D15-46D6-A907-0DBD7E2F4FE1”;
DateTime = “20130802085248.054000+000”;
MachineName = “WROPI01PJ”;
ProcessID = 5840;
SiteCode = “WRO”;
ThreadID = 61672;
};
execmgr 2013-08-02 10:52:48 61672 (0xF0E8)
Successfully created a content request handle {5257F3D8-DFF1-41C1-A7C1-73B91DA47E6D} for the package WRO0006A version 1 execmgr 2013-08-02 10:52:48 61696 (0xF100)
Program Gimp 2.8.4 change to state STATE_ADVANCED_DOWNLOAD content in progress execmgr 2013-08-02 10:52:48 61696 (0xF100)
Execution Request for advert WRO20146 package WRO0006A program Gimp 2.8.4 state change from NotExist to AdvancedDownload execmgr 2013-08-02 10:52:48 61696 (0xF100)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID=”WRO0006A”,ProgramID=”Gimp 2.8.4″, actionType 1l, value , user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 2013-08-02 10:52:48 61696 (0xF100)
Mandatory execution requested for program Gimp 2.8.4 and advertisement WRO20146 execmgr 2013-08-02 10:52:48 61696 (0xF100)
Creating mandatory request for advert WRO20146, program Gimp 2.8.4, package WRO0006A execmgr 2013-08-02 10:52:48 61696 (0xF100)
Raising event:
[SMS_CodePage(852), SMS_LocaleID(1045)]
instance of SoftDistWaitingContentEvent
{
AdvertisementId = “WRO20146”;
ClientID = “GUID:9CD52450-3D15-46D6-A907-0DBD7E2F4FE1”;
DateTime = “20130802085248.144000+000”;
MachineName = “WROPI01PJ”;
PackageName = “WRO0006A”;
PackageVersion = “1”;
ProcessID = 5840;
ProgramName = “Gimp 2.8.4”;
SiteCode = “WRO”;
ThreadID = 61696;
};
execmgr 2013-08-02 10:52:48 61696 (0xF100)
Successfully raised SoftDistWaitingContentEvent event for program Gimp 2.8.4 execmgr 2013-08-02 10:52:48 61696 (0xF100)
Execution Request for advert WRO20146 package WRO0006A program Gimp 2.8.4 state change from WaitingDependency to WaitingContent execmgr 2013-08-02 10:52:48 61696 (0xF100)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID=”WRO0006A”,ProgramID=”Gimp 2.8.4″, actionType 1l, value , user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 2013-08-02 10:52:48 61696 (0xF100)
Raising client SDK event for class CCM_Program, instance CCM_Program.PackageID=”WRO0006A”,ProgramID=”Gimp 2.8.4″, actionType 1l, value NULL, user NULL, session 4294967295l, level 0l, verbosity 30l execmgr 2013-08-02 10:52:48 62952 (0xF5E8)

So i was stupid now ๐Ÿ™‚ The entry says Program Gimp 2.8.4 change to state STATE_ADVANCED_DOWNLOAD content in progress but it isn’t!

I was googling a little bit more, and find this blog entry:

http://blogs.technet.com/b/configmgrteam/archive/2013/07/17/issues-reported-with-ms13-052-kb2840628-and-configmgr.aspx

“Issue 3: Configuration Manager 2007” says about issue I had, although it was saying about SCCM 2007 I decided to give it a shot ๐Ÿ™‚

To make change you need to make change is SQL Management studio on SCCM database:

sccmkberror

 

After that change, all tha packages started to be properly distributed to clients ๐Ÿ™‚